قبل از نصب دایرکت ادمین شما نیاز به نصب نرم افزار های پیش نیاز دایرکت ادمین در سرور لینوکس خود دارید ، بدون نصب این package ها در سرور خود دایرکت ادمین شما به درستی کار نخواهد کرد ، بهتر است قبل از نصب دایرکت ادمین شما سرور خود را به طور کامل ریلود کنید تا مشکلات دیگر ایجاد نشود. برای نصب نرم افزار های پیش نیاز دایرکت ادمین شما باید دسترسی به مدیریت سرور لینوکس خود یا همان SSH دارید ، بعد از لاگین کردن به مدیریت سرور خود باید دستورات زیر را وارد نمایید :

نرم افزار های پیش نیاز دایرکت ادمین

نصب برنامه های پیش نیاز دایرکت ادمین :

برای سیستم عامل Redhat/Fedora/Centos :

yum install wget gcc gcc-c++ flex bison make bind bind-libs bind-utils openssl openssl-devel perl quota libaio libcom_err-devel libcurl-devel gd zlib-devel zip unzip libcap-devel cronie bzip2 cyrus-sasl-devel perl-ExtUtils-Embed autoconf automake libtool which patch mailx bzip2-devel db4-devel

رفع خطا بسته نصب libcom_err-devel در Centos 6 در این مقاله نوشته شده است.

برای Centos 7 :

نصب تمام موارد بالا و بدون db4-devel و سپس نصب موارد زیر به صورت جداگانه :


yum install psmisc net-tools systemd-devel libdb-devel perl-DBI xfsprogs

Debian 6 :

apt-get install gcc g++ make flex bison openssl libssl-dev perl perl-base perl-modules libperl-dev libaio1 libaio-dev zlib1g zlib1g-dev libcap-dev bzip2 automake autoconf libtool cmake pkg-config python libreadline-dev libdb4.8-dev libsasl2-dev patch

Debian 7 :

apt-get install gcc g++ make flex bison openssl libssl-dev perl perl-base perl-modules libperl-dev libaio1 libaio-dev zlib1g zlib1g-dev libcap-dev bzip2 automake autoconf libtool cmake pkg-config python libdb-dev libsasl2-dev libncurses5-dev patch libjemalloc-dev

Debian 8 :

-get install gcc g++ make flex bison openssl libssl-dev perl perl-base perl-modules libperl-dev libaio1 libaio-dev zlib1g zlib1g-dev libcap-dev bzip2 automake autoconf libtool cmake pkg-config python libdb-dev libsasl2-dev libncurses5-dev libsystemd-dev bind9 quota libsystemd-daemon0 patch libjemalloc-dev

FreeBSD :

pkg_add -r gmake perl wget bison flex gd cyrus-sasl2 cmake python autoconf libtool libarchive mailx

FreeBSD 10 :

pkg install gcc gmake perl5 wget bison flex cyrus-sasl cmake python autoconf libtool libarchive iconv bind99 mailx
سپس شما باید دایرکت ادمین را نصب نمایید. توجه کنید که برای نصب این پیش نیاز ها نیازی به فعال بودن لایسنس دایرکت ادمین ندارید.

امیدواریم این مقاله برای شما مفید بوده باشه ، در صورتی که نظر یا مشکلی در مورد پیش نیاز های دایرکت ادمین دارید آن را در زیر همین صفحه برای ما ارسال فرمایید.

منبع : مرکز آموزش دایرکت ادمین